$re = '/^(0[1-9]|[12][0-9]|3[01])[- \/.](0[1-9]|1[012])[-\/.]((19([6-9]\d|5[6-9]))|200[0-2])$/m';
$str = '11/12/1956
11/12/1955
11/12/2002
11/12/2020
10/05/1960
01/09/1957
1/9/1957
32/9/1957
31/13/1988
30/12/1999
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);