$re = '/(?i)((^[aeiou])|(\s+[aeiou]))\w+[aeiou]\b/m';
$str = 'Arline ate eight apples and one orange while Anita hadn\'t any
Not match
a_match_i
a_no_match_
A_match_I
A_NO_match_';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);