import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\@][A-Za-z0-9_]{1,15}$";
final String string = "@ryanmaclean365\n"
+ "@really_ryan\n"
+ "@really-ryan\n"
+ "@1234567890123456\n"
+ "@123456789012345\n"
+ "really ryan\n"
+ "@really ryan\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}