# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"This is the Start for the Test : 1([\S\s]*?) This is the End for the Test : 1"
test_str = ("1) /* This is the Start for the Test : 1 */\n"
"2) Lu8_Ret = GetStatus_1();\n"
"3) Lu8_Ret = Lu8_Ret + 1;\n"
"4)/* This is the End for the Test : 1 */\n"
"5)\n"
"6) /* This is the Start for the Test : 2 */\n"
"7) Lu8_Ret = GetStatus_2();\n"
"8) Lu8_Ret = Lu8_Ret + 1;\n"
"9) /* This is the End for the Test : 2 */\n"
"10) \n"
"11) /* This is the Start for the Test : 1 */\n"
"12) Lu8_Ret = GetStatus_1();\n"
"13) /* This is the End for the Test : 1 */")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.