using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Release (\d+\.\d+(?:\.\d+)?)";
string input = @"Release 2.6 Now Live
Release 12.46.30 Now Live
Release 2.6.0 Now Live
Release 2.6.1 Now Live";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}