package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(` \s*(( )?[0-9]+(?:\.\d+)?(?:\s*(?:l[ lb ]|lb))?(, )?)+\b`)
var str = `<br><span style="font-size: 15px;"><span style="color: #000000;">• 8.5 lb, 25.4 lb 8.5 lb, 25.4 lb 8.5 lb, 25.4 lb</ `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}