use strict;
my $str = '<br><span style="font-size: 15px;"><span style="color: #000000;">• 8.5 lb, 25.4 lb 8.5 lb, 25.4 lb 8.5 lb, 25.4 lb</ ';
my $regex = qr/ \s*(( )?[0-9]+(?:\.\d+)?(?:\s*(?:l[ lb ]|lb))?(, )?)+\b/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}