$re = '/ \s*(( )?[0-9]+(?:\.\d+)?(?:\s*(?:l[ lb ]|lb))?(, )?)+\b/';
$str = '<br><span style="font-size: 15px;"><span style="color: #000000;">• 8.5 lb, 25.4 lb 8.5 lb, 25.4 lb 8.5 lb, 25.4 lb</ ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);