import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b[HPGX]\\d{3}(?:\\+[HPGX]\\d{3})*\\b";
final String string = "random text H326 H243+H546+H677 H234+H333 some other random texts\n"
+ "X123 X234+X567 X567+X890+X654";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}