const regex = new RegExp('\\b[HPGX]\\d{3}(?:\\+[HPGX]\\d{3})*\\b', 'gm')
const str = `random text H326 H243+H546+H677 H234+H333 some other random texts
X123 X234+X567 X567+X890+X654`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}