package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)MIT-[\d\.\/\-]*`)
var str = ` 2312312321312312 asadas-dasdasdads.ru MIT-1.3.2/14-29
23123123 asadewrewras-deewrewrasdasdads.ru MIT-1.4.1/13-29
2312312321312312 asadas-dasdasdads.ru MIT-1.3.2/2-29
232222 aFEWFWewsadas-dasdasdads.ru MIT-1.3.4/12-30
99999 aFEWFWewrrwerweadas-dasdasdads.ru MIT-1.4.1/4-6 #1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}