import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "MIT-[\\d\\.\\/\\-]*";
final String string = " 2312312321312312 asadas-dasdasdads.ru MIT-1.3.2/14-29\n"
+ " 23123123 asadewrewras-deewrewrasdasdads.ru MIT-1.4.1/13-29\n"
+ " 2312312321312312 asadas-dasdasdads.ru MIT-1.3.2/2-29\n"
+ " 232222 aFEWFWewsadas-dasdasdads.ru MIT-1.3.4/12-30\n"
+ " 99999 aFEWFWewrrwerweadas-dasdasdads.ru MIT-1.4.1/4-6 #1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}