const regex = /(?<prefix>R-)?(?<series>E[1-9][0-9]*)\.(?<ocpu>[1-9][0-9]*)-(?<memory>[1-9][0-9]*)(?:GB)?(?<servermem>\\([0-9-]+\\))?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<prefix>R-)?(?<series>E[1-9][0-9]*)\\.(?<ocpu>[1-9][0-9]*)-(?<memory>[1-9][0-9]*)(?:GB)?(?<servermem>\\\\([0-9-]+\\\\))?', 'gm')
const str = `E3.48-768
E3.48-768-HA
R-E3.128-2048(4-256)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}