// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?<prefix>R-)?(?<series>E[1-9][0-9]*)\.(?<ocpu>[1-9][0-9]*)-(?<memory>[1-9][0-9]*)(?:GB)?(?<servermem>\\([0-9-]+\\))?").unwrap();
let string = "E3.48-768
E3.48-768-HA
R-E3.128-2048(4-256)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}