# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([^rs])(?=\1+)|(rr)(?=r+)|(ss)(?=s+)//g;t' <<< "oiiiiiiii amiggggos passssado Carrrrrrrros"