using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^rs])(?=\1+)|(rr)(?=r+)|(ss)(?=s+)";
string substitution = @"";
string input = @"oiiiiiiii amiggggos passssado Carrrrrrrros";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}