use strict;
my $str = '<p>1<br /><br />2<br /><br /><br />3<br /><br /><br /><br />4<br /><br /><br /><br /><br />5</p>';
my $regex = qr~(<br />)(\1{1,4})~mp;
my $subst = '$2';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";