#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-zA-Z]{2}[0-9]{2}\s?[a-zA-Z0-9]{4}\s?[0-9]{4}\s?[0-9]{3}([a-zA-Z0-9]\s?[a-zA-Z0-9]{0,4}\s?[a-zA-Z0-9]{0,4}\s?[a-zA-Z0-9]{0,4}\s?[a-zA-Z0-9]{0,3})?$"
Local $sString = "DE89 3704 0044 0532 0130 00" & @CRLF & _
"AT61 1904 3002 3457 3201" & @CRLF & _
"FR14 2004 1010 0505 0001 3" & @CRLF & _
"DE89370400440532013000" & @CRLF & _
"AT611904300234573201" & @CRLF & _
"FR1420041010050500013" & @CRLF & _
"DE89 370400440532013000" & @CRLF & _
"A T611904300234573201" & @CRLF & _
"FR1420 041010050500013"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")