#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=^.*Snapdragon.*).*(?=\n)"
Local $sString = "Is there any way to fetch the line with a key value, for eg in the below line" & @CRLF & _
"“local parameter and identifier is Snapdragon” — I need to fetch the entire line " & @CRLF & _
"using the word Snapdragon which is the key value, each time that key value can " & @CRLF & _
"vary and there are close to 100 lines in text file. Any way to retrieve the entire line using the key value?"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")