const regex = /(?=^.*Snapdragon.*).*(?=\n)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=^.*Snapdragon.*).*(?=\\n)', 'gm')
const str = `Is there any way to fetch the line with a key value, for eg in the below line
“local parameter and identifier is Snapdragon” — I need to fetch the entire line
using the word Snapdragon which is the key value, each time that key value can
vary and there are close to 100 lines in text file. Any way to retrieve the entire line using the key value?`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}