using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a.+?href=[""'](?!\.\.)([^""']+)[""'].*?>(.+?)<\/a>";
string input = @"<a href="".."">..</a></td><a href=""Example.pdf"">Example.pdf</a>
<a href=""www.example.com"">Example.pdf</a>
<a href=""http://www.example.com"">Example.pdf</a>";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}