using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*\baxis)(?=.*\bregular)(?=.*\bbluechip)";
string input = @"Axis bluechip regular growth
Mirae Bluechip direct
ABSL 96 direct
Axis bluechip direct
Axis all seasons direct
Axis some seasons ";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}