# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[\r\n]+/\r\n/gm;t' <<< "line 1
line2
luine3
line4"