using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?>.*?(foo|bar|baz)){2}.*(*SKIP)(*F)|(?1)";
string input = @"Foo bar, Cambaz!
My bar, good!
My friend, Cambaz!";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}