$re = '/^(?>.*?(foo|bar|baz)){2}.*(*SKIP)(*F)|(?1)/im';
$str = 'Foo bar, Cambaz!
My bar, good!
My friend, Cambaz!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);