package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*\b(jack\b.*\bjames|james\b.*\bjack)\b.*$`)
var str = `hi jack here is james whats up
'hi james here is jack whats up`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}