using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*[[:space:]]GRAVE:.*)";
string input = @"INFORMAZIONI: Parsing jar:file:/workarea/apache-tomcat/apache-tomcat-7.0.47_GA/webapps/GestioneAutorizzazioni/WEB-INF/lib/zkex-6.5.6.jar!/metainfo/zk/zk.xml
lug 26, 2022 10:30:25 PM org.zkoss.zk.ui.sys.ConfigParser parse:269
INFORMAZIONI: Parsing jar:file:/workarea/apache-tomcat/apache-tomcat-7.0.47_GA/webapps/GestioneAutorizzazioni/WEB-INF/lib/zkmax-6.5.6.jar!/metainfo/zk/zk.xml
lug 26, 2022 10:30:25 PM org.zkoss.zk.ui.sys.ConfigParser parse:269
INFORMAZIONI: Parsing jndi:/localhost/GestioneAutorizzazioni/WEB-INF/zk.xml
lug 26, 2022 10:30:25 PM org.zkoss.zk.ui.http.WebManager <init>:172
INFORMAZIONI: Parsing file:///workarea/apache-tomcat/tomcatGA/confapps/GestioneAutorizzazioni/zk-production.xml
lug 26, 2022 10:30:25 PM org.zkoss.zk.ui.http.WebManager <init>:179
GRAVE: File not found: file:///workarea/apache-tomcat/tomcatGA/confapps/GestioneAutorizzazioni/zk-production.xml
lug 26, 2022 10:30:26 PM org.zkoss.zk.ui.metainfo.DefinitionLoaders parseLang:410
AVVERTENZA: Component jasperreport ignored. Reason: unable to load org.zkoss.zkex.zul.Jasperreport due to java.lang.NoClassDefFoundError: net/sf/jasperreports/engine/JRDataSource
Configuring Spring Security Core ...
... finished configuring Spring Security Core
amministrazione-database: doWithSpring
anagrafe-soggetti: doWithSpring
struttura-organizzativa: doWithSpring
AmministrazioneDatabaseBootStrap: validate
lug 26, 2022 10:30:56 PM org.apache.catalina.startup.HostConfig deployWAR
INFORMAZIONI: Deploying web application archive /workarea/apache-tomcat/apache-tomcat-7.0.47_GA/webapps/probe.war
lug 26, 2022 10:30:58 PM org.apache.catalina.startup.HostConfig deployWAR
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}