#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(\w+)\s+j[^a-zA-Z]*e[^a-zA-Z]*t\b"
Local $sString = "hi jet" & @CRLF & _
"hi jetto" & @CRLF & _
"hello j(e)t(t)o" & @CRLF & _
"hey jellyt" & @CRLF & _
"ji j***e***t"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")