// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(\w+)\s+j[^a-zA-Z]*e[^a-zA-Z]*t\b").unwrap();
let string = "hi jet
hi jetto
hello j(e)t(t)o
hey jellyt
ji j***e***t";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}