package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?P<ip>\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})\s
(?P<name>\w+)\s
(?P<proto>\w+)\s
(?P<http_status_code>\d+)`)
var str = `172.16.1.1 bob tcp 200`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}