#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^\d+|(?<=\w)\d+(?![\d\s])|(?<=\s)\s+"
Local $sString = "**Input**" & @CRLF & _
"Ndd12" & @CRLF & _
"12Ndd12" & @CRLF & _
"Ndd 12" & @CRLF & _
"Nav G45up" & @CRLF & _
"Mr Nave12en "
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)