using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d+|(?<=\w)\d+(?![\d\s])|(?<=\s)\s+";
string substitution = @"";
string input = @"**Input**
Ndd12
12Ndd12
Ndd 12
Nav G45up
Mr Nave12en ";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}