const regex = new RegExp('^\\d+|(?<=\\w)\\d+(?![\\d\\s])|(?<=\\s)\\s+', 'gm')
const str = `**Input**
Ndd12
12Ndd12
Ndd 12
Nav G45up
Mr Nave12en `;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);