#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ":\s+(\")"
Local $sString = " "data": [" & @CRLF & _
" ^ {" & @CRLF & _
" "ServerName": "server.name"," & @CRLF & _
"... ^" & @CRLF & _
"..." & @CRLF & _
" "LastUpdated": "sexta-feira, 23 de outubro de 2020 06:09:09""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")