const regex = new RegExp(':\\s+(\\")', 'g')
const str = ` "data": [
^ {
"ServerName": "server.name",
... ^
...
"LastUpdated": "sexta-feira, 23 de outubro de 2020 06:09:09"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}