const regex = /id="aqiPm10"\s+class="aqi">(\d+)<\/div>/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('id="aqiPm10"\\s+class="aqi">(\\d+)<\\\/div>', '')
const str = `<div id="aqiPm10" class="aqi">9</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}