re = /id="aqiPm10"\s+class="aqi">(\d+)<\/div>/
str = '<div id="aqiPm10" class="aqi">9</div>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end