$re = '/\b[JEF]\d\d\b/m';
$str = 'Trade Unions: Objectives, Structure, and Effects J51
Trade and Labor Market Interactions F16,Wage Level and Structure; Wage Differentials J31
Trade and Labor Market Interactions F16,Wage Level and Structure; Wage Differentials J31
Trade Policy; International Trade Organizations F13
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);