Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(?'first'.+\s)(\k'first')
/
gm
Test String
New
שלום שלום רב לאוהבי תורתך ואין ואין למו מכשול
Substitution
Processing...
\1