// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?'first'.+\s)(\k'first')").unwrap();
let string = "שלום שלום רב לאוהבי תורתך ואין ואין למו מכשול";
let substitution = "\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}