const regex = /(?:\G(?!^);|Seats:\s*)\K\d+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\G(?!^);|Seats:\\s*)\\K\\d+', 'gm')
const str = `Seats: 11;12;
Name: qqqq;wwww;
Start: Прешов, АВ Košická 2725/2
End: Мукачево, АЗ Лавковская, 1б
Date: 2019-06-22
Time: 09:40 PM`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}