re = /(\d{4})(?:.* ((?:[1-9]|1[0-9]|2[0-4]) hour(?: 30 minutes)?))?/m
str = 'Pay for zone 1234 for 1 hour
Pay for zone 4567
Pay for zone 1234 for 13 hour 30 minutes
Pay for zone 1234 for 13 hour 30 minutes
Pay for zone 1234 for 24 hour 30 minutes
Pay for zone 1234 for 25 hour 30 minutes'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end