package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"([^"])*"`)
var str = `"123","ABC", "ABC,DEF", "GHI"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}