re = /^(?=^.{8,}$)(?=.*[a-z])(?=.*\d)(?=.*[A-Z]).*$/m
str = 'Rami123456
Passwordsd23
pass123142'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end