# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?!^).(\(\+\d{1,3}\)?)( *(,|$))//gm;t' <<< " (+966)533356235, (+966)123123, (+966), (+966)"