using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"22?5";
string input = @"3.1/2.6
1.00/5.00
12/19
125
1225
12.34
-567.89";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}