#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([a-zA-Z]*)(?> |-)([0-9]{1,2})(?>, |-)([0-9]{2,4}) ([0-9]{1,2}:[0-9]{1,2}) (AM|PM)?"
Local $sString = "January 2, 2020 4:15 PM" & @CRLF & _
"January-14-20 12:44 PM" & @CRLF & _
"December-24-19 20:15 PM. " & @CRLF & _
"December-24-19 20:15 "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")