import Foundation
let pattern = #"([a-zA-Z]*)(?> |-)([0-9]{1,2})(?>, |-)([0-9]{2,4}) ([0-9]{1,2}:[0-9]{1,2}) (AM|PM)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
January 2, 2020 4:15 PM
January-14-20 12:44 PM
December-24-19 20:15 PM.
December-24-19 20:15
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)