$re = '/(\d+\s+[-]\s+.*?(?=\s+-)|\d+\s+[-].*)/m';
$str = 'Opcao 01 - Frase123 aleatória - Menu Superior
Opcao 02 - Outra123 Frase aleatória - Menu Su
Opcao 03 - Mais123 01 Frase - Menu
Opcao 04 - Mais123 Frase -
Opcao 05 - Frase123 Simples';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);