import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "---\\n[\\s\\S]+?(?=\\n---|$)";
final String string = "---\n"
+ "event: outgoing HTTP response\n"
+ "timestamp: 2021-10-06T08:15:28.212Z\n"
+ "remoteAddress: \"1.2.3.4\"\n"
+ "hostname: a.b.c.domain.com\n"
+ "statusCode: 200\n"
+ "headers:\n"
+ " content-length: 524\n"
+ " etc: ...\n"
+ "body: \"blabla (can be multiline and can contain anything)\"\n"
+ "---\n"
+ "event: outgoing HTTP response\n"
+ "timestamp: 2021-10-06T08:15:28.212Z\n"
+ "remoteAddress: \"1.2.3.4\"\n"
+ "hostname: a.b.c.different.com\n"
+ "statusCode: 200\n"
+ "headers:\n"
+ " content-length: 524\n"
+ " etc: ...\n"
+ "body: \"blabla (can be multiline and can contain anything)\"\n"
+ "---\n"
+ "event: outgoing HTTP response\n"
+ "timestamp: 2021-10-06T08:15:28.212Z\n"
+ "remoteAddress: \"1.2.3.4\"\n"
+ "hostname: 1.2.3.domain.com\n"
+ "statusCode: 200\n"
+ "headers:\n"
+ " content-length: 524\n"
+ " etc: ...\n"
+ "body: \"blabla (can be multiline and can contain anything)\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}